Timely app could be sluggish
Incident Report for Timely Limited
Resolved
Looks like everything is back to normal. Apologies again for that hiccup!
Posted about 1 year ago. Jul 31, 2017 - 14:08 NZST
Investigating
Hey folks, looks like the app is on a go slow right now and logging in might be an issue. Never fear as the techbots are all over this and we expect services to return to normal shortly. Apologies in the meantime if you've been affected and feel free to hit us up at: help@gettimely.com if you're worried.

We'll keep things updated here as we get new information.
Posted about 1 year ago. Jul 31, 2017 - 13:43 NZST