Slow customer searches
Incident Report for Timely Limited
Resolved
All sorted now. Thanks for your patience!
Posted about 2 years ago. Jan 27, 2016 - 17:35 NZDT
Identified
We are currently experiencing slowness with customer searches in the following areas:

- adding a customer to an appointment
- customers tab
- calendar sidebar

Please bear with us while we work on addressing this.
Posted about 2 years ago. Jan 27, 2016 - 14:02 NZDT