Intermittent connectivity issues
Incident Report for Timely Limited
Resolved
This incident has been resolved.
Posted over 2 years ago. Jan 08, 2016 - 12:17 NZDT
Identified
We are experiencing issues with one of our servers which we are working on. If you have trouble accessing Timely please try again.
Posted over 2 years ago. Jan 08, 2016 - 11:32 NZDT