Issues with Timely web app
Incident Report for Timely Limited
Resolved
The fix has now been deployed and everything is back to normal. Apologies for any inconvenience caused.
Posted 11 months ago. Sep 19, 2017 - 11:03 NZST
Identified
There are currently a couple of known issues with Timely caused by an update earlier today:

1. Unable to delete payments from invoices
2. Display issues for Firefox users

A fix for both issues is expected within the next 30 minutes. For issue #2, you can use the Google Chrome browser as a workaround. You can download and install Chrome here: https://www.google.com/chrome

We will provide a further update when the fix is applied.
Posted 11 months ago. Sep 19, 2017 - 09:57 NZST