Slow app performance
Incident Report for Timely Limited
Resolved
This incident has been resolved.
Posted about 2 years ago. Feb 22, 2016 - 18:56 NZDT
Investigating
We're having some intermittent server issues causing slowness. Please be patient while we resolve these.
Posted about 2 years ago. Feb 22, 2016 - 18:09 NZDT