Dashboard and reports running slow
Incident Report for Timely Limited
Resolved
This incident has been resolved.
Posted 11 months ago. Nov 24, 2017 - 08:02 NZDT
Investigating
We are investigating some issues with the dashboard and reports running slowly. Apologies for any inconvenience this is causing you.
Posted 11 months ago. Nov 23, 2017 - 20:13 NZDT