Timely running slower than normal
Incident Report for Timely Limited
Resolved
This incident has been resolved.
Posted about 1 year ago. Aug 01, 2017 - 20:32 NZST
Identified
There have been performance problems with Timely today between 2pm and 2.30pm (NZT), as well as problems yesterday and Friday around similar times.

The good news is that we have discovered the source of these problems. Overnight we'll upgrade our systems which we're very confident will resolve things.

If your business has been impacted by this, we'd like to sincerely apologise. We know how painful this kind of slowness can be when you're servicing customers. Please be assured the tech team has been, and continues to be, 100% focused on getting things back to normal.

Please reach out to our support team if you need any further assistance.

Kind Regards,
Andrew Schofield
CTO | Timely
Posted about 1 year ago. Aug 01, 2017 - 14:49 NZST