Performance issues
Incident Report for Timely Limited
Resolved
Apologies for any inconvenience caused by this outage. The good news is that performance is now back to normal which includes the dashboard. Phew!
Posted almost 2 years ago. Sep 07, 2016 - 15:19 NZST
Identified
The cause of the performance issues has been identified and is being worked on. Also, the Dashboard is currently down but everything else should be returning to normal.
Posted almost 2 years ago. Sep 07, 2016 - 14:38 NZST
Investigating
The Timely app is experiencing a few performance issues right now. The Techbots are on the case and should have this sorted in a jiffy.

If you have any questions, feel free to email us at: help@gettimely.com
Posted almost 2 years ago. Sep 07, 2016 - 14:17 NZST